Problem Set 0: Scratch

due by noon on Thu 9/8

Per the directions at this document’s end, submitting this problem set involves filling out a Web-based form that may take a few minutes, so best not to wait until the very last minute, lest you spend a late day unnecessarily.

Objectives.

- Introduce some fundamental programming constructs.
- Empower you to design your own animation, game, or interactive art.
- Impress your friends.

**diff pset0.pdf hacker0.pdf.**

- Hacker Edition requires integration with a Sensor Board (aka PicoBoard or Scratch Board).
- Hacker Edition recommends more technical reading on hard disk drives.
Academic Honesty.

All work that you do toward fulfillment of this course’s expectations must be your own unless collaboration is explicitly allowed in writing by the course’s instructor. Collaboration in the completion of problem sets is not permitted unless otherwise stated by some problem set’s specification.

Viewing or copying another individual’s work (even if left by a printer, stored in an executable directory, or accidentally shared in the course’s virtual terminal room) or lifting material from a book, website, or other source—even in part—and presenting it as your own constitutes academic dishonesty, as does showing or giving your work, even in part, to another student or soliciting the work of another individual. Similarly is dual submission academic dishonesty: you may not submit the same or similar work to this course that you have submitted or will submit to another. Nor may you provide or make available solutions to problem sets to individuals who take or may take this course in the future. Moreover, submission of any work that you intend to use outside of the course (e.g., for a job) must be approved by the staff.

You are welcome to discuss the course’s material with others in order to better understand it. You may even discuss problem sets with classmates, but you may not share code. In other words, you may communicate with classmates in English, but you may not communicate in, say, C. If in doubt as to the appropriateness of some discussion, contact the course’s instructor.

You may turn to the Web for instruction beyond the course’s lectures and sections, for references, and for solutions to technical difficulties, but not for outright solutions to problems on problem sets or your own final project. However, failure to cite (as with comments) the origin of any code or technique that you do discover outside of the course’s lectures and sections (even while respecting these constraints) and then integrate into your own work may be considered academic dishonesty.

All forms of academic dishonesty are dealt with harshly. If the course refers some matter to the Administrative Board and the outcome for some student is Admonish, Probation, Requirement to Withdraw, or Recommendation to Dismiss, the course reserves the right to impose local sanctions on top of that outcome for that student that may include, but not be limited to, a failing grade for work submitted or for the course itself.

Grades.

Your work on this problem set will be evaluated along two axes primarily.

Scope. To what extent does your code implement the features required by our specification?
Correctness. To what extent is your code consistent with our specifications and free of bugs?

All students, whether taking the course Pass/Fail or for a letter grade, must ordinarily submit this and all other problem sets to be eligible for a passing grade (i.e., Pass or A to D–) unless granted an exception in writing by the course’s instructor.
Getting Started.

☐ O hai! Know that help with this and future problem sets is available not only at office hours, per the schedule on the course’s website, but also via help.cs50.net. We’ll do our best to reply to posts on the latter within 24 hours!

☐ If you haven’t picked up a Sensor Board already, print out and fill out the form at this document’s end. Bring the completed form to office hours and hand the form to a member of the staff in exchange for a Sensor Board (aka Scratch Board or PicoBoard) plus accessories.¹ Alternatively, post privately to the Problem Set 0: Hacker Edition category at help.cs50.net to set up, if possible, an alternative day and time for pickup.

We suspect demand for Sensor Boards may exceed our supply, so if you know someone who also plans to tackle this Hacker Edition, allow us to suggest that you consider sharing a board, borrowing it under just one of your names, so that we have more to go around! Just realize that you’ll each need to build your own projects. If you don’t (yet) know anyone in CS50, post privately to the Problem Set 0: Hacker Edition category at help.cs50.net, and we can introduce you to someone who already picked up a board.

☐ Obtain an FAS (Faculty of Arts and Sciences) Computer Account, if you haven’t one already, by visiting the URL below and following the on-screen instructions.

https://idm.fas.harvard.edu/new

Not only will this account provide you with access to FAS’s computer facilities, it will also provide you with an email address of the form username@fas.harvard.edu, where username is your FAS username.² Take care to remember your username and password!³

Itching to Program?

☐ Surf on over to the URL below and sign up for an account on MIT’s website by clicking Signup atop the page.

http://scratch.mit.edu/

Any username (that’s available) is fine, but take care to remember it and your choice of password.

¹ Note that Sensor Boards, manufactured by MIT, and PicoBoards, manufactured by PICO, are functionally identical but look slightly different. In particular, they have different logos, and PicoBoards have little handles on their sliders. Some PicoBoards are even red. We bought some of each; it doesn’t matter which one you borrow!

² You don’t actually need to use this email address, but if you would like to, visit http://www.fas-it.fas.harvard.edu/services/catalog/browse/36/46/726 for instructions.

³ If you ever forget your FAS username and/or password or have trouble with your FAS account, you’ll want to contact FAS IT by phone at 617-495-9000, in person in Science Center B-14, or via email at help@fas.harvard.edu.
☐ Then head to the URL below and take note of the resources available to you before you dive into Scratch itself.

http://info.scratch.mit.edu/Support

In particular, you might want to skim the Getting Started Guide.

☐ Next, read through the tutorial below, which presents Scratch in terms a (soon-to-be) programmer should understand.

http://www.cs.harvard.edu/malan/scratch/

☐ If not already installed on the computer you’re using, download Scratch itself via the URL below.45

http://scratch.mit.edu/download

Take care to download version 1.4. Once downloaded, install the software by double-clicking its icon and/or following any on-screen directions. If unsure how to install, don’t hesitate to ask at help.cs50.net!

☐ Next install a driver for your Sensor Board as per the instructions at:

http://www.picocricket.com/picoboardsetupserial.html

If you’re running Windows (particularly a 64-bit version thereof) and have trouble getting your computer to recognize the Sensor Board, you might instead want to try the driver at:

http://cdn.cs50.net/2011/fall/psets/0/PL2303_Prolific_DriverInstaller_v1417.zip

If you’re running Mac OS (particularly Snow Leopard or Lion) and have trouble getting your computer to recognize the Sensor Board, you might instead want to try the driver at:

http://cdn.cs50.net/2011/fall/psets/0/md_PL2303_MacOSX10.6_dmg_v1.4.0.zip

☐ Head to

http://scratch.mit.edu/projects/cs50/267149

where IceMonkey, by David Wu ’11, awaits. You should find yourself at MIT’s website with a monkey (screenshot below) embedded in your browser.

---

4 Installers for Linux are available at http://info.scratch.mit.edu/Linux_Installer.
5 Students running an operating system other than a supported version of Linux, Mac OS, or Windows should please find a computer with a supported operating system to use for this problem set (e.g., in the Science Center, a house’s lab, or a friend’s room).
If you do not see David’s project, you may need to download and install a “Java Runtime Environment” (aka “Java Virtual Machine” or “JVM”). To do so, follow the link to Java at https://www.cs50.net/software/, follow any on-screen instructions, then return to MIT’s website.

Note, though, that you can’t actually play David’s project within your browser because it requires a Sensor Board. Go ahead, then, and download the project’s “source code” (i.e., its .sb file). Click the link labeled davidwu in the page’s top-right corner, just below Download this project! If told by a pop-up to log in, click the link labeled Login toward the page’s top-left corner and log in with the username and password that you created earlier for MIT’s website, then click davidwu again. If prompted to open or save the file (called davidwu.sb), go ahead and save it to your desktop so that it’s easy to find.

Then launch the non-browser version of Scratch (i.e., the one you downloaded and installed earlier) by clicking its own icon on your desktop, in your Applications folder, or wherever you installed it. Click File → Open... toward Scratch’s top-left corner, and navigate your way to David’s project, wherever it ended up on your hard drive.

Once David’s project has loaded, click Scratch’s green flag! Move your Sensor Board’s slider back and forth and see if the monkey responds. If not, wait a few seconds (albeit at the risk of being stunned) while Scratch scans your computer for a Sensor Board. If the monkey remains unresponsive (when not stunned) or you get tired of waiting, click Sensing toward Scratch’s top-left corner, then right-click (on a PC) or ctrl-click (on a Mac) the block labeled sensor value or the block labeled sensor toward Scratch’s bottom-left corner, then select show ScratchBoard watcher in the contextual menu that appears. A diagnostic window should appear that you can drag anywhere on Scratch’s stage. If it reports that that your Sensor Board is Off or if all sensor values appear to be 0, right-click (on a PC) or ctrl-click (on a Mac) anywhere on the watcher and select select serial/USB port in the contextual menu that appears. You should then see a list of available COM ports (on a PC) or available device files (on a Mac). You can either try all possible options, testing each one to see if it works, or look for clues as to which one is right.

For clues on a PC, right-click My Computer (or Computer) in your Start menu, select Properties, then look for your computer’s Device Manager. Expand the Ports (COM and LPT) subtree, if not
expanded already, and look for a Prolific USB-to-Serial Comm Port. Ideally, the device’s COM port should appear in parentheses. If not, right-click the entry, select Properties from the contextual menu that appears and poke around the tabs in the window that then appears.

For clues on a Mac, select About This Mac from your Apple menu and click More Info... to pull up your computer’s System Profiler. Expand the Hardware subtree, if not expanded already, click USB, and look for a USB-Serial Controller. That won’t reveal the name of its device file, but its presence or absence should confirm or deny that your Sensor Board (or, at least, your serial-to-USB cable) has been detected.

If none of those tips get you on your way, also check out pages 8 and 9 of PICO’s own documentation at the URL below.


If you’re still stuck, go ahead and post to the Problem Set 0: Hacker Edition category at help.cs50.net describing your problem in detail. In particular, tell us what OS you’re using and what you’ve tried already.

Once you do get your Sensor Board up and running, see how many bananas you can catch! Actually, call a roommate over to your computer, and see how many he or she can!

☐ If you haven’t already, read up on what you can do with your Sensor Board by skimming PICO’s documentation at the URL below.


If you’d like to see additional projects that utilize Sensor Boards, check out the galleries below.

http://scratch.mit.edu/galleries/view/21836
http://scratch.mit.edu/galleries/view/5630

☐ Now it’s time to choose your own adventure! Your mission is, quite simply, to have fun with Scratch and implement a project of your choice (be it an animation, a game, interactive art, or anything else), subject only to the following requirements.

i. Your project’s filename must be username.sb, where username is your FAS (not MIT) username in all lowercase.

ii. Your project must have at least two sprites, at least one of which must resemble something other than a cat.

iii. Your project must have at least three scripts total (i.e., not necessarily three per sprite).

iv. Your project must use at least one condition, one loop, and one variable.

v. Your project must use at least one sound.

vi. Your project should be more complex than most of those demonstrated in lecture (many of which, though instructive, were quite short). In fact, it should probably be about as complex as, say, IceMonkey.

vii. Your project must use a Sensor Board for some form(s) of input.
Feel free to peruse additional projects online or those that come with Scratch for inspiration, but your own project should not be terribly similar to any of them. Try to think of an idea on your own, and then set out to implement it. But don’t try to implement the entirety of your project all at once: pluck off one piece at a time. David Wu, for instance, probably implemented a movable monkey before he proceeded to implement falling objects.

If, along the way, you find it too difficult to implement some feature, try not to fret; alter your design or work around the problem. If you set out to implement an idea that you find fun, you should not find it hard to satisfy this problem set’s requirements. If you suspect your program might fall short of our expectations, feel free to ask a member of the staff for an opinion prior to submitting.

Alright, off you go. Make us proud! If you have questions or want a hand making your project even better, do take advantage of office hours. Alternatively, post questions to help.cs50.net!

☐ Once finished with your project, upload it to your account on MIT’s server by clicking Share → Share This Project Online... toward the top of Scratch’s window. Provide “Your Scratch website login name” (i.e., username) and password that you chose earlier, some project notes (e.g., some instructions or a description), and zero or more tags; ensure that your “Project name” is your FAS username. Best to leave Compress sounds and images checked. Then click the OK button. Assuming you’re informed that “Your project is now online at scratch.mit.edu,” head on over to the URL below. 

http://scratch.mit.edu/login

Log in (if you aren’t still logged in) with your username and password. Once logged in, click my stuff toward the page’s top-right corner. You should see the project you just uploaded among My Projects. Go ahead and click its name or icon. Your project should be embedded (and start playing) in the window that appears. Take note of the URL in your browser’s address bar. That’s your project’s URL on MIT’s website, and you’ll need to know it later.

Note that some projects, particularly those with sound or that require a Sensor Board, do not function properly when embedded in MIT’s website. Not to worry! We’ll be sure to download your .sb file and open it in the non-browser version of Scratch.

☐ When done admiring your work, head on over to the URL below.

https://www.cs50.net/galleries/2011/fall/scratch

Make sure that you’re still logged into MIT’s website. (If you see “Welcome” followed by your username atop the page, you are.) If not, click Login to log in again.

---

6 If informed that your project is too large to be uploaded, try to decrease its size by clicking Edit → Compress Sounds... and/or Edit → Compress Images... atop Scratch’s window. You may need to experiment with different levels of compression. Also take care to remove from each of your sprites any sounds that you imported but ended up not using. If, despite many attempts, you are still unable to upload your project to MIT’s website because of its size, best to email help@cs50.net for advice.
Toward the page’s right-hand side, click add my projects and wait for a window to appear. Once that window appears, click your own project’s name, wait for a checkmark to appear to in the box to the left of it, then click Accept. If you return to the URL above, you should find that your project has been added to Fall 2010’s gallery for others to enjoy. If not, try once more or contact the staff for assistance.

If you really, really don’t want your work included in the course’s gallery, you may opt out of this particular step. But you must still upload your project to MIT’s server (by clicking Share → Share This Project Online...), per the previous step. And you must still “submit” your project to us, per this document’s end.

How Stuff Works.

☐ Head to

http://en.wikipedia.org/wiki/Hard_disk_drive

and read up on how hard disk drives (aka HDDs) work. You may also want to re-watch the two videos we saw on Friday of Week 0, both of which are linked under Week 0’s Demos at:

https://www.cs50.net/lectures/

Once you feel you’ve wrapped your mind around the technology, try explaining how HDDs work in a few sentences verbally to a roommate or friend. (For real!) There are far too many people in this world who know what they’re talking about but do not know how to explain what they know to non-technical people, so consider it very good practice! Plus, we may ask you to explain them to us before long. ;-)

Submitting Your Work.

☐ When you’re ready to “submit” your project to us, surf on over to the URL below to answer some questions.

https://www.cs50.net/psets/0/

You’ll find that a few questions await. Be extra-sure that your answers are correct, particularly your email address(es) and your project’s URL, else we may overlook your submission! And be sure to click Submit on the last page of that form in order to submit this, your first CS50 problem set!

☐ kthxbai!